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Typographical Styles
Throughout this document we have used several typographic styles to mark specific 
things.

● Red Bold Text – Text marked with red bold text indicates things that require 
special attention. Usually paragraphs started with red bold text are things that 
you either want to make sure you do, or are things you may not want to do.

● Bold text – Bold text indicates the names of files or folders (directories), or 
partial file names.

● Italicized text – Italicized text indicate things that you need to click on. Any 
button or tab we talk about is also shown in italicized text.

● Monospace font – Text written in a monospace font on a light gray 
background are things that you need to type in. Text in a monospace font 
on a white background is simply text that you will see displayed in the 
Terminal or dialog box.
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0. Project Overview
Do you want to give your GTK or Xfce desktop a dash of Mac OSX? Do you want to 
change the default look of your desktop to something like this? Then read on....

Is that Mac OSX Leopard??? Naah... Its just GNU/Linux + (GNOME|Xfce) + Mac4Lin!

The goal of this project is to bring the look and feel of Mac OSX on GNU/Linux and 
Unix-System like GTK, KDE and Xfce based systems. This document will present the 
procedure to install Mac4Lin pack & tweak certain things to get that almost perfect 
Mac OSX like desktop.

Mac4Lin Version 1.0 now includes a script that makes the install process much 
easier. Steps handled by the script will be indicated by the icon on the right. In 
addition, Mac4Lin now works on and Xfce-based systems, in addition to 
GNOME based systems, although there is another file that covers the installation of 
Mac4Lin on an Xfce system. 

Note: Backup all files before deleting/replacing the original ones. The Mac4Lin 
development team is not responsible for any loss of data that may occur when 
installing and/or during the usage of Mac4Lin.
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1. Getting Mac4Lin

Download the Mac4Lin .tar.gz file from http://sourceforge.net/project/mac4lin/. 
Once it's saved to your hard drive, locate it and right click on it, selecting Extract 
Here from the context menu.

Once you've extracted it open a Terminal and navigate to the location you 
extracted it to, i.e. cd ~/Desktop/Mac4Lin_v1.0 if you saved and extracted 
the file to your Desktop. The you need to run the install script by running 

./Mac4Lin_Install_v1.0.sh.

You'll see the script go through its  paces as it starts installing things.

*************************************

  Welcome to Mac4Lin v1.0 Installer

*************************************

Installing Mac4Lin UI...

Done!

Installing Mac4Lin Icons...

Done!

Installing Mac4Lin Cursors...

Done! Please enable the cursor theme from Appearances.

Installing Mac4Lin Emerald Window Borders...

Done!

Installing Mac4Lin misc. components...

The next thing the script will want to do is to install some things that need 
administrative access, but you have the right to do it yourself.

The following components require root access. You can opt out of 
installing them as they can be manually installed as well.

Would you like to install these components [y/n]?
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If you say no, you will see

Components requiring root access not installed. Kindly install 
them manually.

If you say yes it will ask for your password and then install the GDM Login Theme 
and Sounds and the GDM Theme.

Installing Mac4Lin GDM Login Theme and Sounds...

[sudo] password for [your username]:

Setting GDM Theme

Done!

Please assign the sounds to events manually. All sounds are 
saved in /usr/share/sounds

The installation script can't change the settings for your system sounds so you'll 
need to do it yourself. You can find them all in /usr/share/sounds. The script will 
continue to run and will install the Mac4Lin Background and Pidgin theme. You'll see 
a note that says

The current Pidgin theme has been backed up as 
~/Mac4Lin_v1.0/Backup/pidgin_backup.tar.gz

Note that Mac4Lin_v1.0 will be in your home folder

Please enable the Pidgin AWN plugin from within Pidgin and place 
a launcher for Pidgin on AWN

If you already have a launcher for Pidgin set up on your dock you shouldn't find any 
issues. You will want to double check in Pigdin that the AWN plugin is enabled. The 
plugin allows AWN to change the icon based on your status and activity, as described 
in section 12.

Whether you let the installation script install components that require administrative 
access or not when the script finishes you'll see

****************************************

     Mac4Lin installation complete!

  Please refer to the documentation for

   advanced installation instructions

   (for installing usplash, grub etc.)
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 For best results, log off and log back

   in for all changes to be effected

****************************************

Press any key to continue...

For best results you should log out and then log back in. You don't need to reboot, 
but you should definitely use System → Quit... → Log Out to make sure all of the 
changes you made are set properly.

There are still some manual changes you need to make but this gets you through the 
main part of the installation. The next section will start looking at rest of the things 
that you need to do, mostly manually, to install Mac4Lin.
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 Instructions for GNOME 2.22 Systems

This section of the documentation is written for GNOME 2.22 based systems. The 
GNOME version can be checked by clicking on System > About GNOME. If your 
computer runs an earlier version of GNOME you may want to refer to the older 
documentation, available for downloading as a PDF document at 
http://sourceforge.net/projects/mac4lin/. The screenshots shown may differ from 
your computer, but these were taken on a system starting with the Human-Murrine 
Theme.

2. GTK Metacity Theme

    2.1 Installing the GTK Metacity theme

Go to System → 
Preferences → 
Appearance. If you 

ran the installation script 
you will see a new theme 
labeled Custom... This is 
due to a glitch in how the 
theme installed, but if you 
scroll down you'll see two 
new themes called 
Mac4Lin_Aqua and 
Mac4Lin_Graphite. The the 
thumbnails show the 
Mac4Lin_Aqua theme uses 
colorful “traffic lights” for 
the Minimize, 
Maximize/Restore and Close 
buttons and check 
boxes/radio buttons, while 
the Mac4Lin_Graphite uses a 
more neutral set of buttons. 
The theme you should use 
is purely a matter of personal preference.

You will also see a pair of themes labeled Mac4Lin_MacMenu_Aqua and 
Mac4Lin_MacMenu_Graphite. The last two themes are for those running the Global 
Menu (MacMenu) hack. If you aren’t sure of what the Global Menu (MacMenu) is and 
don't know if you've installed it you should stick to the themes that don't say 
MacMenu.

Please Note: The MacMenu hack brings the OSX standard of all menus appearing in a 
single location, in the top panel on your desktop. As of this writing it still doesn't 

Mac4Lin 1.0 Documentation 7

http://sourceforge.net/projects/mac4lin/


work with all applications, especially non-GTK applications (notably including the 
Opera web browser, Mozilla Firefox and Thunderbird, and the OpenOffice.org office 
productivity suite), but there are community members who are hard at work to bring 
MacMenu out of the realm of hacks and into the real of a real option for Linux, 
especially GNOME, users. For more information read the thread at 
http://ubuntuforums.org/showthread.php?t=241868 in the Ubuntu Forums and the 
Global Menu wiki page at https://wiki.ubuntu.com/global_menu).

Select the theme you want to use (you should only use the MacMenu themes if you've 
specifically installed MacMenu). Despite what the installation script said the Mac4Lin 
Cursors will already be enabled when you select which Mac4Lin theme you want to 
use.

Mac4Lin 1.0 Documentation 8

https://wiki.ubuntu.com/global_menu
http://ubuntuforums.org/showthread.php?t=241868


    2.2 Shifting the order of the titlebar buttons

The installation script will move the “traffic lights”, the minimize, maximize 
and close buttons, on the left hand side of the titlebar in Metacity 
(instructions for using the Emerald/Compiz Fusion theme appear in Section 

3). If you want to make the change manually, press Alt+F2 and type in gconf-editor. 
Press Enter or click Run and a new window should appear. In the sidebar, go to / → 
apps → metacity → general. Back on the right hand side, double click on 
button_layout. Delete the value that's there and type in 
menu:minimize,maximize,close. Then Click OK and close the application 
Configuration Editor. The buttons will now be on the left side of titlebar. To restore 
the buttons to the original layout, just replace the string with 
close,minimize,maximize:menu.
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3. Using the GTK Icon Theme
As soon as you enable one of the Mac4Lin themes you have all of the Mac4Lin icons. 
The theme also includes icons for many applications, as well as for the basic parts of 
a GNOME-based GTK/Linux distribution. You will, however need to add some applets 
to complete the OSX look.

     3.1. Adding the necessary panel applets

For the Search/Network/ Wi-Fi icon to 
work correctly, you need to add 
relevant applets to your GNOME panel. 
Right click on an empty area on the 
GNOME panel and select Add to 
panel... Then scroll down and select the 
Search for files applet. Now again 
follow the first part, this time select the 
Network Monitor Applet. Look at the 
main screenshot for suggested 
placements on the panel.

     3.2. Extra “goodie” icons

This theme also contains a lot of 
extra icons. To access them, Go 
to Places → Home Folder and 
press Ctrl+H: A number of new 
folders should appear. Look for 
the one named .icons and open 
it. Then open the Mac4Lin Icons 
folder and you should see a 
folder named EXTRAS. Double 
click the folder to open it. Some 
of the icons in the pack are 
shown on the left
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4. Emerald Compiz Theme
If you are using Ubuntu, it will come with Compiz Fusion pre-enabled. You just need 
to install your graphic card driver (if you need to, that is). After that go to 
Applications → Accessories → Terminal. Type in sudo aptitude install emerald. 
That will install Emerald, a window decorator you will need if you don’t like the GTK 
window decorator.

The installation 
script installs 
two Emerald 

themes, but you will 
have to enable the one 
you want to use. Go to 
System → Preferences 
→ Emerald Theme 
Manager. Scroll down 
until you see the 
Mac4Lin themes and 
select either the 
Mac4Lin_Emerald_ v1.0 
theme if you use the 
Aqua GTK theme or the 
Mac4Lin_Graphite_ 
Emerald_v1.0 theme if 
you use the Graphite 
GTK theme. Once you 
click on the theme it will be enabled, so once you have the theme you want enabled 
simply click Quit to close the Emerald Theme Manager.
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5. GTK Cursor Theme
The installation script installs the Mac4Lin Cursor Theme automatically, and 
when you activate one of the Mac4Lin themes You will also enable the cursor 
theme.

6. GDM Login Window Theme

     6.1 Installing the GDM login theme

Unfortunately the installation script won't install the GDM theme properly so you'll 
need to install it manually.

Go to System → Administration → Login Window (entering your Administrator 
password when asked) and select the Local tab. Click the Add button and select the 
file Mac4Lin_GDM_v1.0.tar.gz. Scroll down until you see the Mac4Lin GDM with it's 
preview and click the circle next to the it to select the theme. Make sure Selected 
only is chosen above as Theme, or else you will have a random theme selected from 
any theme checked when you log in. Click the Close button and log out (System → 
Administration → Log Out) to verify that you have the Mac4Lin GDM Login Theme 
enabled.
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Here's a sample screenshot of the Mac4Lin GDM Login theme:
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7. GTK Splash

     7.1. Configuring the GTK splash theme with gTweakUI

Although gTweakUI hasn’t been updated since 2004, it is still very easy to apply the 
splash theme with it.

To install it, Go to Applications → Accessories → Terminal and type in sudo aptitude 
install gtweakui. Once it's installed leave the Terminal window open for now.

Type in “sudo nautilus” (without quotes) and in when the Nautilus window opens  it 
will look different because it won't use the same theme that you have selected. 
Navigate to the  /home/<your username>/<the extracted Mac4Lin folder>. Copy all 
splash images files from the GTK_Splash folder to the folder /usr/share/pixmaps/
splash.

Now go to System → Preferences → gTweakUI → Session. Then click on the big 
square at the bottom and select the image you want as your splash screen.
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     7.2. Configuring the GTK splash theme with Ubuntu Tweak

This application is used by a lot of Ubuntu users, and is updated regularly, so this is 
the better choice if you want to keep up-to-date. With the release of Ubuntu Tweak 
0.3.4 it can now keep itself updated, as well as several other programs. You can get 
the current version of Ubuntu Tweak at http://ubuntu-tweak.com/.

Go to Applications → Accessories → Terminal and type in sudo nautilus and in the 
address bar, type in /home/<your username>/<the extracted Mac4Lin folder>. 
Copy all the images files from the folder /Mac4Lin_v1.0/GTK to the folder 
/usr/share/pixmaps/splash.

Now go to Applications → System Tools → Ubuntu Tweak. On the sidebar, go to 
Startup → Session Control. Click the big box at the bottom to change the splash 
screen.
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8. Usplash Screen (Boot splash)

     8.1. Installing the Usplash startup theme

The installation script can't install the Usplash boot theme so you'll need to do it 
yourself. First go into the folder that you extracted Mac4Lin into (not the 
Mac4Lin_v1.0 folder that the installation script created), and open the Usplash folder. 
Select both files in that folder, right click them, and select Extract Here. That will get 
you the actual Usplash themes that you need.

Configuring start-up related things are made easy with the application StartUp-
Manager. To install go to Applications → Accessories → Terminal, and type in sudo 
aptitude install startupmanager. Don't close the Terminal after installing StartUp-
Manager.

Important: Use StartUp-Manager at your own risk. If you mess it up, your computer 
might not boot up properly! It is strongly recommended that you back up the GRUB 
menu list before you do anything with StartUp-Manager. Open up Terminal again 
(with Applications → Accessories → Terminal) and type in sudo cp 
/boot/grub/menu.lst /boot/grub/menu.lst.copy.

Once you have the two Usplash files extracted go to System → Administration → 
StartUp-Manager. In the Boot options tab, check the Show boot splash option under 
Misc.. Now move to the Appearance tab.
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Click on Manage usplash themes... near the bottom and in the new pop-up, press 
Add. Browse to where the .so files have been placed and add them. Now click the 
drop-down menu and select your Usplash theme.
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Sample screenshot of Bootsplash screen:
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9. Font Configuration

     9.1. Installing the Mac OSX fonts

Firstly, go to the extracted Mac4Lin folder and look for the subfolder Fonts. Right 
click and press Extract Here on the file Fonts.tar.gz. A new folder, fonts,  should 
appear. Open it and you should see a collection of forty-four .ttf files.

To install Mac OSX fonts, goto Places → Home Folder. You need to show hidden 
configuration folders and files, and you already know how to do it: press Ctrl+H. If 
you don't see a folder called .fonts, right click anywhere and press Create Folder. 
Name it .fonts. Now simply all of .ttf files from the extracted folder above to the 
.fonts folder.

An example of font settings 
using the newly added fonts:
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10. GRUB Splash
You will again need StartUp-Manager to configure this part. If you still haven’t 
installed it, goto Applications → Accessories → Terminal and type in sudo aptitude 
install startupmanager. Now go to System → Administration → StartUp-
Manager.

Use this software at your own risk, if you mess 
it up, your computer might not boot up properly! 
So it is strongly recommended that you back up 
the GRUB menu list before you do anything with 
StartUp-Manager. Open up Terminal again (by 
Applications → Accessories → Terminal) and type 
in sudo cp /boot/grub/menu.lst 
/boot/grub.menu.lst.copy. Don't close the 
Terminal yet, though.

Now type in sudo open nautilus. When the file 
browser opens up, type in the address bar 
/boot/grub. Right click, press Create Folder, and 
name it splash. Copy and paste all .xpm.gz files 
from the Mac4Lin folder GRUB.

Goto System → Administration → StartUp-
Manager. Goto the Appearance tab. Now click on 
Manage bootloader themes... and click Add. 
Locate the .xpm.gz image you want to set as the GRUB boot screen and add it. Select 
the image from the Grub background image button.
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11. Launcher Docks

Compiz is required to run Avant Window Navigator (AWN.) Like mentioned earlier, 
Ubuntu now has Compiz enabled by default, you may just need to install your 
graphics driver. (We have not listed AWN from Ubuntu’s repositories because it lacks 
features we need.)

          11.1.1. Installing the latest version of AWN

You can get installation instructions for AWN for Ubuntu/Debian, Gentoo, Mandriva, 
Fedora, openSUSE and Arch Linux from the AWM Wiki (http://wiki.awn-
project.org/DistributionGuides). For Ubuntu we recommend using reacocard's PPA 
due to the fact that the official repository packages may be missing some features 
we need. You can get instructions for installing AWN from reacocard's PPA from his 
thread on the Ubuntu Forums at http://ubuntuforums.org/showthread.php?
t=762363.

You can also install it from the source code from the instructions at http://wiki.awn-
project.org/InstallingFromSource.

          11.1.3. Installing the AWN theme

Goto System → Preferences → Awn Manager. On the sidebar, click Themes, and back 
on the right, press Add. Locate to the extracted Mac4Llin pack and open the folder 
named AWN. double click the .tgz file inside, and after the theme is added, check 
the circle (next to the theme preview.) Press Apply.

          11.1.4 Extra AWN customizations

You might also want to do these following things:

• On the sidebar of Awn Manager, click General. At the top, click the tab 
General, and check the option Automatically start AWN on login.

• In the Bar Appearance tab, choose 3D look from the drop-down of Look and 
uncheck Enable rounded corners.

• This is the emulation of the Mac OSX Dock’s Stacks. Goto System → 
Preferences → Awn Manager. Goto Applets (on the sidebar), and look for an 
applet named Stacks Applet. Click it, then click Activate. A new icon should 
appear on your dock. Right click it and press Preferences. 

• On the tab Backend, check Folder backend and navigate to the folder you 
want this applet to display. You can also use the File backend and simply 
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drag and drop the items you want in your Stacks.

• Goto the Applet Layout tab and for the Applet title, name it what you want 
displayed on the dock. (For example, Leopard has it named “Downloads” for 
all downloaded files by default.)

• We don't have custom icons for your Stacks, but you can click the box for 
Composite applet icon to use an icon based on the file types you have in 
your Stacks. You can also change the Empty icon and Full icon If you have 
icons you want to use. Click the images and in the new pop-up, navigate to 
the folder housing your icons, They are probably in the .icons folder off of 
your Home folder (~/.icons).

• Finally, goto the tab Stack Layout and choose Curved gui from the drop-
down for an OSX-like curve to your Stacks.

• Click Apply to close the Preferences window. If the folder has a lot of items 
you may find a delay before you are able to use the AWN Stacks applet.

     11.2. Cairo-Dock

Some people like AWN, but some people love the Cairo-Dock (http://www.cairo-
dock.org/). Most of their site is in French, but they do have a section of their wiki in 
English (http://www.cairo-dock.org/ww_page.php?p=Accueil&lang=en).

While you don't need Compiz to run Cairo-Dock (or AWN) you do need some kind of 
compositor like xcompmgr or the metacity compositor. We suggest you look into 
both dock technology and decide which one serves your needs best. The plugins and 
applets we provide are for AWN, however.

          11.2.1. Installing Cairo-Dock

Goto System → Administration → Software Sources, and goto the Third-Party 
Software tab. Click Add... and type deb http://repository.cairo-
dock.org/ubuntu. Press OK, then click Add again. This time, type in deb-src 
http://repository.cairo-dock.org/ubuntu. and OK, Close, then Reload. Open 
up Terminal and type in sudo aptitude install cairo-dock cairo-dock-plug-
ins.
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12. Widget Layer

     12.1. Installing Screenlets, making a widget layer, etc.

Screenlets are a great way to add OSX-like widgets to your Ubuntu desktop. Tom 
Dryer created a great HOWTO on installing Screenlets, and in addition to showing 
you how to install it he also has information on getting an OSX-style dashboard.

Rather than reprint it all here and possibly miss an update to the page, we'll provide 
you with a link to the tutorial on his Tombuntu.com website.

http://tombuntu.com/index.php/2008/03/17/os-x-like-widgets-with-screenlets-on-ubuntu-3rd-
update/
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13. Pidgin Theme and Plugins
Pidgin, the default Instant Messenger for Ubuntu, has the ability to communicate 
with your AWN dock and change the icon according to your current Pidgin status. 
There is also a Pidgin iChat Theme to let it look like the OSX iChat program. These 
instructions will show you how to install the plugin and theme in Pidgin 2.5.x.

     13.1. Pidgin Plugin for AWN

If you have installed previous versions of the Pidgin plugin for AWN please close 
Pidgin and delete the old plugin before installing the new version. This will prevent 
any problems when you install the new version. If you're not sure where it may be 
installed, open a Terminal window and run locate pidgin_awn. This will provide 
you with a list of all known copies of the plugin. You want to look for locations such 
as ~/.purple/plugins and /usr/lib/pidgin.

Move (or copy) the file pidgin_awn.so to ~/.purple/plugins. If the plugins folder 
doesn't exist in ~/.purple you can create it yourself. Create a launcher for Pidgin in 
AWN, and launch it. Once Pidgin opens go to Tools → Plugins to open the Plugins 
window. Look for the AWN plugin and click the checkbox to enable it. You'll see a 
change in your icon on AWN immediately. right click on the Pidgin tray icon and 
select Plugins. Enable the AWN plug in.

Default Pidgin icon on the AWN Dock:

Status Idle/Invisible:

Status Available:

Status Connecting: 

Status Offline:

Unread message (number of unread 

messages are shown): 
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     13.2. Pidgin iChat Theme

While the Pidgin supports smiley and Guification themes, right now it doesn't 
support themes, or “skins”. The devs are working on a Theme Manager for a future 
version of Pidgin, but it currently right now it gets it's theme from the active GTK 
theme. Luckily that means it can get some theme elements from the Mac4Lin GTK 
theme we installed back in section 7. Unfortunately the default Pidgin look still 
doesn't being a true OSX look to the program, even with the Mac4Lin GTK theme.

To fix that we've included an iChat theme for Pidgin. You will need close Pidgin for 
this next step so go ahead and make sure Pidgin is completely closed and not just 
minimized to your notification area. Open a file manager window to where you 
extracted the installation files for Mac4Lin and open the Pidgin folder. You'll see the 
from the current Extract the theme archive to a temporary folder. In the Pidgin folder 
from the extracted Mac4Lin files you'll see a file called Mac4Lin_Pidgin_v1.0.tar.gz. 
That's the Pidgin iChat Theme, so right click on it and select Extract Here, which will 
give you a folder called pidgin. With the ~/Mac4Lin_v1.0/Pidgin folder open in your 
file manager you'll need to open another file manager, although this new one needs 
administrative rights so run sudo nautilus in a Terminal and in the window that 
opens navigate to /usr/share/pixmaps.

You'll see that there's already a pidgin folder there so we'll need to replace it. You 
may want to back up this folder in case you need it again so make a copy of it before 
you do anything else. Now click and drag the pidgin folder from the 
~/Mac4Lin_v1.0/Pidgin  folder where you extracted it from to the window with 
/usr/share/pixmaps. (You can Ctrl-click and drag the folder to copy the folder to 
make sure you leave a copy where you extracted it. You'll see a plus sign next to the 
cursor to show that the selected item is being copied.) You'll get a dialog box 
warning you that there's already a folder named pidgin and asking what you want to 
do. Click the button that says Merge All since the folder has subfolder. Another 
dialog box will pop up warning you that there's already a file named previous.png. 
Click on the Replace All button and wait for the files to be copied over. This will 
install the iChat Theme for Pidgin.

Due to the way that Pidgin handles it's theme you will need to reinstall this theme 
anytime you install and update or upgrade to Pidgin or the update process will 
overwrite the iChat icons with the new default versions.
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This is a screenshot of Pidgin with iChat Theme:
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14. Exaile Avant-Window-Navigator Plugin
If you use the Exaile Music Player there is an AWN plugin that you can use to show 
the album cover art for the track currently playing, as well as the progress and/or 
remaining time on the AWN dock. We used to include it with Mac4Lin but it's getting 
updated fairly regularly so we decided to simply let you get it from Exaile. The Exaile 
Music Player is available in the Ubuntu Universe repository for both Hardy Heron and 
Intrepid Ibex. If you want a newer version than the official repository you can get it 
from  the Exaile Developers Personal Package Archive (PPA) at 
https://launchpad.net/~exaile-devel/+archive. If you use the PPA make sure 
you're using the proper sources for the version of Ubuntu that you're using.

Launch Exaile and go to Edit → Plugins 
→ Available Plugins. Select the AWN 
plugin and click the Install checkbox 
for beside it, then click the Install 
button. When you see the plugin fall off 
the list switch to the Installed Plugins 
tab, select the AWN plugin and click on 
the Configure button. Select whichever 
option you prefer, then click OK to 
close the dialog and click the Close 
button when you're finished with your 
plugins. The status will now be shown 
on the Exaile launcher on AWN, 
depending on which option you 
selected on the configuration dialog.

PLEASE NOTE: Some users have not been able to use this Plugin. So it may or may 
not work for you.

Idle Exaile icon on AWN: 

Exaile icon showing the song's progress: 

Exaile icon showing the remaining time: 

Exaile icon showing the album cover but no extra
information:

Mac4Lin 1.0 Documentation 27

https://launchpad.net/~exaile-devel/+archive


15. Mac OSX Sounds

     15.1. Mac4Lin System Sounds

Mac4Lin now comes with two sets of sounds, System Sounds and Pidgin sounds. 
Starting with the system sounds, go to the Sounds folder where you extracted 
Mac4Lin, select the Mac4Lin_Sounds_v1.0.tar.gz file and right click on it by selecting 
Extract Here. Open the resulting folder and you will see the 34 files that come with 
Mac4Lin. Open a Nautilus window with administrative rights by running sudo 
nautilus in a Terminal (or with Alt-F2) and navigate to /usr/share/sounds. Copy 
the folder from where you extracted it to /usr/share/sounds and you can easily 
select the sounds for GTK events.

Open the Sounds screen at System → Preferences → Sound → Sounds. There you can 
assign sounds to events as you wish. An example screen is shown here:
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     15.1. Mac4Lin Pidgin Sounds

With Mac4Lin 1.0 we've added a set of sounds for use in Pidgin as well as the system 
sounds. Extract the Mac4Lin_Pidgin-Sounds_v1.0.tar.gz file and copy them to 
/usr/share/sounds as you did with the system sounds and set them up as you like 
by using Tools→ Preferences → Sounds.
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16. iTunes media player skin
Copy the Mac4Lin_MP_v1.0.tar.gz 
file from the MP folder to the 
appropriate skin folder. You may 
need to extract the archive and move 
the Mac4Lin_iTunes_v0.4 folder to 
the location indicated for each media 
player below. If the folder does not 
exist you can create it.

1) XMMS (no longer supported by 
Ubuntu, XMMS2 has no GUI)

~/.xmms/Skins folder

2) Beep Media Player (replaced by 
BMPx, which doesn't support skins at this time)

~/.bmp/skins folder

3) Audacious

~/.local/share/audacious/Skins folder

After extraction goto the Preferences > Skin and select the Mac4Lin iTunes skin to 
apply. 

Note: ~/ indicates the folder /home/<user name>
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17. Firefox and Thunderbird Themes and Extensions

17.1 Firefox Extensions

Open the Firefox Add-ons Manager by selecting Tools→ Add-ons, and drag & drop 
the .xpi files from the Mac4Lin Mozilla/Firefox/FF2Extensions folder to the Firefox 
Add-ons Manager window. The versions we're including in Mac4Lin will work with 
Firefox 3.0.x and are the latest versions available at the time of Mac4Lin's release. 
We recommend that you use Firefox's add-on update feature to periodically check 
for updated versions of the extensions.

When the Software Installation window opens and you are able to, click the Install  
Now button. Once the extension is installed restart Firefox.
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     17.2. MacOSX Firefox Themes

Previous versions of Mac4Lin used the Vfox|Finder theme, but it hasn't been updated 
for use with Firefox 3.  DrP has been kind enough to take the Mac OSX Theme and 
customize it for Mac4Lin. There are two versions included, one for OSX-style 
scrollbars with the buttons at the bottom and one for the usual Linux-style 
positioning of the scrollbar buttons at the top and bottom of the bar. You can pick 
the version you want to use.

To install the themes simply open the Add-ons Manager window again and drag & 
drop the .jar file onto the Themes tab. As above, click the Install Now button when it 
is available. Restart Firefox once the theme is installed to use the theme. 

After applying the extensions and add ons Firefox will now look like this:
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     17.3 Thunderbird Themes and Extensions

There are also themes and extensions for Mozilla's Thunderbird email client. Install 
them the same way you did for Firefox and your Thunderbird will join in the OSX-
themed goodness.
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18. Mac4Lin and WINE
WINE (Wine Is Not an Emulator) is the software that will let you run most Windows 
programs on Linux systems, but WINE doesn't take the theme components from your 
system like other apps do. Simply edit ~/.wine/user.reg to make the following 
changes.

Find where it says 

[Control Panel\\Colors] 1218068727

and replace that with 

[Control Panel\\Colors] 1221187215 
"ActiveBorder"="190 190 190" 
"ActiveTitle"="186 186 186" 
"AppWorkSpace"="128 128 128" 
"Background"="128 0 128" 
"ButtonAlternateFace"="186 186 186" 
"ButtonFace"="186 186 186" 
"ButtonHilight"="210 210 210" 
"ButtonLight"="186 186 186" 
"GradientActiveTitle"="186 186 186" 
"GradientInactiveTitle"="186 186 186" 
"Hilight"="0 120 210" 
"HotTrackingColor"="0 120 210" 
"InactiveBorder"="182 182 182" 
"InactiveTitle"="186 186 186" 
"InactiveTitleText"="98 98 98" 
"InfoWindow"="226 226 226" 
"Menu"="186 186 186" 
"MenuBar"="186 186 186" 
"MenuHilight"="0 120 210" 
"Scrollbar"="220 220 220" 
"TitleText"="0 0 0" 
"Window"="255 255 255" 

And right below that add

[Control Panel\\Desktop\\WindowMetrics] 1218132115 
"BorderWidth"="1" 
"CaptionFont"=hex:f4,ff,ff,ff,00,00,00,00,00,00,00,00,00,00,00,0
0,90,01,00,00,\ 
00,00,00,00,00,00,00,22,42,00,69,00,74,00,73,00,74,00,72,00,65,0
0,61,00,6d,\ 
00,20,00,56,00,65,00,72,00,61,00,20,00,53,00,61,00,6e,00,73,00,0
0,00,00,00,\ 
00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,0
0 
"CaptionHeight"="18" 
"CaptionWidth"="18" 
"MenuFont"=hex:f4,ff,ff,ff,00,00,00,00,00,00,00,00,00,00,00,00,9
0,01,00,00,00,\ 
00,00,00,00,00,00,22,42,00,69,00,74,00,73,00,74,00,72,00,65,00,6
1,00,6d,00,\ 
20,00,56,00,65,00,72,00,61,00,20,00,53,00,61,00,6e,00,73,00,00,0
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0,4d,00,6f,\ 
00,6e,00,6f,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00 
"MenuHeight"="18" 
"MenuWidth"="18" 
"MessageFont"=hex:f5,ff,ff,ff,00,00,00,00,00,00,00,00,00,00,00,0
0,90,01,00,00,\ 
00,00,00,00,00,00,00,22,42,00,69,00,74,00,73,00,74,00,72,00,65,0
0,61,00,6d,\ 
00,20,00,56,00,65,00,72,00,61,00,20,00,53,00,61,00,6e,00,73,00,0
0,00,00,00,\ 
00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,0
0 
"ScrollHeight"="16" 
"ScrollWidth"="16" 
"Shell Icon Size"="32" 
"SmCaptionFont"=hex:f5,ff,ff,ff,00,00,00,00,00,00,00,00,00,00,00
,00,90,01,00,\ 
00,00,00,00,00,00,00,00,00,4d,00,53,00,20,00,53,00,68,00,65,00,6
c,00,6c,00,\ 
20,00,44,00,6c,00,67,00,00,00,00,00,00,00,00,00,00,00,00,00,00,0
0,00,00,00,\ 
00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,0
0,00 
"SmCaptionHeight"="15" 
"SmCaptionWidth"="13" 
"StatusFont"=hex:f5,ff,ff,ff,00,00,00,00,00,00,00,00,00,00,00,00
,90,01,00,00,\ 
00,00,00,00,00,00,00,22,42,00,69,00,74,00,73,00,74,00,72,00,65,0
0,61,00,6d,\ 
00,20,00,56,00,65,00,72,00,61,00,20,00,53,00,61,00,6e,00,73,00,0
0,00,00,00,\ 
00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,0
0

With those changes made your Wine Configuration window will look like this:
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19. Desktop Backgrounds

     19.1. Applying the desktop backgrounds

In the Mac4Lin folder that you extracted you will find a folder named 
Wallpapers. The first wallpaper has been installed for you by the installation 
script, but there's a second wallpaper you can use as well. Both images 

measure 2560x1600 pixels and are formatted for widescreen monitors, but you can 
easily edit them in GIMP or your favorite image editing program to fit your screen 
resolution. 

You will also find a file called Leopard_Wallpapers.tar.gz in the Mac4Lin SourceForge 
download area that contains 17 other wallpaper images that you can use. As with the 
wallpapers included with Mac4Lin they are formatted for wides monitors and all are 
2560x1600 pixels (except where specified).

Copy the images to anywhere you want (default is /usr/share/backgrounds), then 
right click on your desktop and choose Change Desktop Background. Click Add..., 
locate the image you want to set your wallpaper to and double click!

Mac4Lin 1.0 Documentation 37



Congratulations!
Installation is now complete. Congratulations! You now have the Mac OSX user 
interface on your GTK desktop.
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20. FAQ and Troubleshooting
     1. Q: Compiz won’t work.

         A: Try going to System → Administration → Hardware Drivers and enabling 
your graphics card. Your system will automatically download any drivers if necessary. 
Restart afterwards, and Compiz should start automatically.

     2. Q: I started AWN, but I can’t see it!

         A: You need Compiz to run AWN. Try doing the steps described above.

     3. Q: Mac OSX cursor doesn’t stay when I switch to Compiz!

         A: Goto Applications → Accessories → Terminal and type in “sudo aptitude 
install compizconfig-settings-manager” (without the quotes.) After, goto System → 
Preferences → Advanced Desktop Effects Settings/CompizConfig Settings Manager. 
Click General Options and change the Cursor theme to the one you want.

     4. Q: What is Global Menu (MacMenu)?

         A: Ctrl+click this link.

     5. Q: Does Mac4Lin 1.0 work with GNOME versions older than 2.22?

         A: No. Go here and download v0.4 for GNOME 2.20 and 2.18. You shouldn’t be 
running an older version of GNOME than that.

     6. Q: Does this version work on Ubuntu Intrepid?

         A: As a matter of fact it does! A week before Ubuntu 8.10 was released we 
discovered that they have changed things enough that some theme elements in 
Mac4Lin 1.0 don't completely work with Ubuntu Intrepid. Since then we've found the 
problem and fixed it so you should have no problems using Mac4Lin 1.0 under 
Ubuntu 8.10 Intrepid Ibex. If you have problems, please let us know either in the 
support thread (http://ubuntuforums.org/showthread.php?p=5767692) or by filing 
a bug on our SourceForge site (https://sourceforge.net/projects/mac4lin).
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21. Credits and Information
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• DrP for the Mozilla Firefox/Thunderbird themes

• Laviano for urging me to release MacMenu version of GTK theme

• Maurizio for the GDM concept
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I also thank all those who tested beta releases of Mac4Lin and everyone who is 
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For any bug reports, comments, complaints or suggestions, please head to the 
project website and/or drop me a mail at infra_red_dude.users@sourceforge.net.

No part or whole of this guide should be reproduced without permission. The Apple 
logo is NOT bundled with the package. It is only for demonstration purpose.

Anirudh R. Acharya (a.k.a infra_red_dude)
Developer, Mac4Lin

E-Mail: infra_red_dude.users@sourceforge.net
Project Website: http://sourceforge.net/projects/mac4lin
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